Truzta - Truzta App is down – Incident details
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Get updates
Dark mode
All systems operational
Truzta App is down
Resolved
Major outage
Started about 1 month ago
Lasted about 1 hour
Affected
Truzta App
Operational from 12:56 AM to 12:56 AM, Major outage from 12:56 AM to 1:56 AM
Updates
Resolved
June 15, 2025 at 1:56 AM
Resolved
June 15, 2025 at 1:56 AM
Truzta App is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
June 15, 2025 at 12:56 AM
Investigating
June 15, 2025 at 12:56 AM
Truzta App is down at the moment. This incident was automatically created by Instatus monitoring.